Investigating - Sui Mainnet Degraded Performance

Incident Report for Alchemy

Investigating

The Sui chain is currently stalled at block 280,692,037. This is a network-wide issue impacting multiple providers. Our team is actively monitoring and coordinating with the Sui team. We will provide updates as the situation develops.
Posted May 28, 2026 - 16:14 UTC
This incident affects: Sui.