Elevated Latency on Katana Mainnet

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 20:29 UTC

Investigating

We are currently investigating elevated latency on Katana Mainnet. Our team is actively looking into the issue and working to mitigate impact.
Posted Feb 18, 2026 - 17:34 UTC