[Network-Wide] Ethereum Sepolia Degraded Performance

Incident Report for Alchemy

Update

We are continuing to investigate this issue.
Posted May 16, 2026 - 01:36 UTC

Investigating

We are currently investigating degraded performance on Ethereum Sepolia. Block production has been intermittent, with the chain's head advancing unevenly.

This appears to be a network-wide issue. Alchemy's infrastructure is operating normally and we do not currently anticipate customer-facing impact.

We will continue to monitor and provide updates as we learn more.
Posted May 16, 2026 - 01:28 UTC
This incident affects: Ethereum.