Elevated Latency on Robinhood Mainnet

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Aug 12, 2026 - 02:33 UTC

Identified

The issue has been identified and we're working on a fix.
Posted Aug 12, 2026 - 02:00 UTC

Investigating

We’re currently investigating an issue causing elevated latency and increased 5xx errors on Robinhood Mainnet. We’ll share additional updates as soon as we have more information.
Posted Aug 12, 2026 - 01:19 UTC