Investigating - Sonic Blaze Block Stall

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Feb 22, 2026 - 14:15 UTC

Investigating

We are currently investigating a chain-wide block stall on the Sonic Blaze testnet. This is a network-level issue affecting the chain itself, and we are in contact with the Sonic team. We will provide updates as we learn more.
Posted Feb 22, 2026 - 06:56 UTC