Story Mainnet: Network-wide Block Production Stall

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Aug 10, 2026 - 17:11 UTC

Investigating

We are investigating a network-wide stall on Story Mainnet. Block production has halted at block 20818220 and requests for the latest block may return stale data until the chain resumes. We are coordinating with the Story team and working to resolve this ASAP.
Posted Aug 10, 2026 - 12:29 UTC
This incident affected: Story.