[Cloudflare incident] Elevated 503 error rate

Incident Report for Alchemy

Resolved

The elevated 503 errors impacting Alchemy services have now been resolved. The root cause was a short Cloudflare network incident. Cloudflare implemented fixes, and our monitoring confirms that 503 errors are no more. See Cloudflare status page: https://www.cloudflarestatus.com/incidents/9pvscr0vmsy6
Posted Sep 09, 2025 - 19:37 UTC

Update

Cloudflare have implemented a fix and we're monitoring the situation.
Posted Sep 09, 2025 - 19:21 UTC

Investigating

Cloudflare identified an incident across all of their products. Alchemy services may be interrupted and customers may see 503 errors.
Posted Sep 09, 2025 - 19:09 UTC