Lens Testnet Issues

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jul 09, 2025 - 19:10 UTC

Investigating

We're actively investigating issues impacting Lens Testnet
Posted Jul 09, 2025 - 17:26 UTC
This incident affected: Lens.