5xx Errors With Some APIs (Cloudflare-related)

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 10:18 UTC

Monitoring

Cloudflare is currently experiencing an outage that is causing elevated 5xx errors across certain API endpoints. Their engineering team has deployed a fix and is actively monitoring service stability. Additional details can be found on the Cloudflare status page:

https://www.cloudflarestatus.com/incidents/lfrm31y6sw9q
Posted Dec 05, 2025 - 09:23 UTC