Robinhood Mainnet - Increased Latency in APAC

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Sep 09, 2026 - 01:14 UTC

Investigating

A subset of requests on Robinhood Mainnet are experiencing increased latency in the APAC region.
Posted Sep 08, 2026 - 22:14 UTC
This incident affected: Robinhood.