[Network Wide] Celo Alfajores Stuck on Block 51109972

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jul 09, 2025 - 14:00 UTC

Investigating

Cela Alfajores block production is stalled on block 51109972 - see explorer here: https://alfajores.celoscan.io/block/51109972

This is a network wide incident and we're working with Celo team for a fix!
Posted Jul 09, 2025 - 13:13 UTC
This incident affected: Celo.