BNB Smart Chain Mainnet - Degraded Performance

Incident Report for Alchemy

Resolved

We have confirmed full recovery across our BNB Smart Chain Mainnet infrastructure. All nodes are healthy and serving traffic normally, with response times and error rates back to baseline. This incident is now resolved. Thank you for your patience!
Posted Jul 22, 2026 - 14:43 UTC

Identified

We experienced node-level failure on BNB Mainnet which caused a subset of our nodes to become unavailable. As a result, increased load was placed on our remaining infrastructure, further contributing to degraded response times. A node binary fix was deployed and we are seeing recovery.
Posted Jul 22, 2026 - 11:02 UTC

Investigating

We are investigating elevated error rates and increased latency on BNB Smart Chain Mainnet. Some requests may fail or respond slower than usual. Our team is actively working on a fix and we will post updates here as we learn more.
Posted Jul 22, 2026 - 07:45 UTC
This incident affected: BNB Smart Chain.