[Network Wide] Linea Sepolia Block Stalled

Incident Report for Alchemy

Resolved

Block production is back up!
Posted Nov 12, 2025 - 16:27 UTC

Investigating

We're currently seeing a block stalled on Linea Sepolia - last block mined was 20640643: https://sepolia.lineascan.build/block/20640643
Posted Nov 12, 2025 - 15:29 UTC
This incident affected: Linea.