Finalized Block Stalled on Unichain Mainnet

Incident Report for Alchemy

Resolved

Our nodes caught-up and finalized block is up to date
Posted Jul 09, 2025 - 03:15 UTC

Investigating

We're seeing the Finalized block stalled on 21275800 since ~01:42 UTC

This is related to this incident from Unichain: https://status.unichain.org/cmcvcwdwv001oc3nwefxc4k17

Our nodes are catching-up and will update this status page accordingly!
Posted Jul 09, 2025 - 01:42 UTC
This incident affected: Unichain.