Tron Testnet Stalled

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jan 08, 2026 - 18:02 UTC

Monitoring

A fix has been implemented, and we’re monitoring as we begin to see recovery.
Posted Jan 08, 2026 - 17:51 UTC

Identified

The issue has been identified and we are working on a fix.
Posted Jan 08, 2026 - 16:38 UTC

Investigating

We are currently investigating an issue that is causing 503 errors on Tron Testnet.
Posted Jan 05, 2026 - 22:20 UTC