Degraded Performance on Hyperliquid_Mainnet

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 00:43 UTC

Investigating

We are currently observing degraded performance across the Hyperliquid mainnet node fleet. This condition may surface as null responses for certain request paths. Our team is analyzing the impact and will provide updates as we gather additional telemetry.
Posted Nov 18, 2025 - 13:33 UTC
This incident affected: HyperEVM.