Polygon Mainnet Chicago Hardfork

Scheduled for May 21, 14:00 - 16:00 UTC

Update

Polygon Mainnet will undergo Chicago Hardfork at the scheduled time.

The HF updates gas pricing for selected EVM opcodes and precompiles. These changes improve gas-cost alignment with execution cost and help maintain network stability.

We are not expecting any downtime.

Additional Information:
https://forum.polygon.technology/t/bor-v2-8-0-and-erigon-v3-6-0/21875
Posted May 18, 2026 - 08:40 UTC

Scheduled

We will be undergoing scheduled maintenance during this time.
Posted May 18, 2026 - 08:36 UTC
This scheduled maintenance affects: Polygon.