Elevated 5xx errors across our Data APIs on multiple networks

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 17:15 UTC

Investigating

We are currently investigating this issue.
Posted Jul 08, 2025 - 16:51 UTC