Elevated Errors on BNB Mainnet

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 18:44 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 28, 2025 - 17:27 UTC

Identified

Archival nodes are currently stalled.
Posted Oct 28, 2025 - 15:58 UTC

Investigating

We are currently investigating this issue.
Posted Oct 28, 2025 - 15:53 UTC
This incident affected: BNB Smart Chain.