[Network Wide] Polygon Amoy : Gap in archive data

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Nov 16, 2025 - 06:20 UTC

Investigating

Archive nodes on Polygon Amoy are currently stuck at a specific block height (29020819) and not progressing. Historical queries remain available but the delay may impact access to the latest blocks.
Posted Nov 14, 2025 - 06:08 UTC
This incident affected: Polygon.