Soneium Mainnet Service Degradation

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jul 21, 2026 - 22:42 UTC

Investigating

We are currently investigating an issue impacting transaction propagation on Soneium Mainnet.
Posted Jul 21, 2026 - 20:49 UTC
This incident affected: Soneium.