[Network Wide] Botanix Testnet Stalled

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 17:55 UTC

Investigating

We're currently seeing Botanix Testnet block production stalled on block 3072275: https://3636.testnet.routescan.io/block/3072275

This is a network wide incident and we're working closely with Botanix team!
Posted Jul 07, 2025 - 12:40 UTC