Degraded Performance on SEI Testnet

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jan 26, 2026 - 19:14 UTC

Monitoring

A fix has been implemented and we are observing recovery across affected nodes. We will continue to monitor and provide updates.
Posted Jan 26, 2026 - 18:41 UTC

Investigating

SEI Testnet is experiencing chain-wide degradation with block production halted. The last validated block is 227,172,199, confirmed approximately 3 hours ago: https://testnet.seistream.app/blockchain

We are coordinating with the SEI team to monitor network recovery. Updates will follow as the situation progresses.
Apologies for any disruption to your development workflow.
Posted Jan 26, 2026 - 16:31 UTC
This incident affected: SEI.