[Network-wide] Blast Sepolia block production issues

Incident Report for Alchemy

Update

We are continuing to investigate an issue affecting Blast Sepolia nodes, where some nodes are falling behind the chain head following the v1.7.0 network upgrade. Our team is actively working with the Blast network team to identify the root cause and restore full sync. We will share another update as soon as we have more information.
Posted Feb 17, 2026 - 20:56 UTC

Investigating

Blast Sepolia is currently experiencing network-wide issues following yesterday's hardfork, with block production lagging approximately 12 hours behind.

We have reached out to the Blast team and are monitoring the situation closely.
Posted Feb 12, 2026 - 17:31 UTC
This incident affects: Blast.