Investigating - Ink Sepolia Safe and Finalized Block Degradation

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted May 28, 2026 - 11:31 UTC

Investigating

We are investigating reports of degraded performance on Ink Sepolia. The finalized and safe block tags are currently not progressing reliably, affecting requests that rely on those block parameters.

This appears to be a chain-wide issue. We will provide updates as more information becomes available.
Posted May 28, 2026 - 05:43 UTC
This incident affected: Ink Chain.