MegaETH performance degraded

Incident Report for Alchemy

Update

The current degradation is due to an ongoing stress test being conducted by MegaETH. Some performance impact is expected during this period. Check out their dedicated page for real-time metrics and more details: https://stress.megaeth.com/
We will continue monitoring and provide updates as needed.
Posted Jan 27, 2026 - 12:22 UTC

Investigating

We are currently seeing degraded performance on our MegaETH nodes.
Posted Jan 23, 2026 - 05:02 UTC