Zetachain Mainnet

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Sep 03, 2025 - 18:03 UTC

Investigating

We are currently seeing issues with our Zetachain Mainnet nodes. Our team is actively investigating.
Posted Sep 03, 2025 - 16:40 UTC
This incident affected: Zetachain.