Monad Mainnet - Increased eth_getLogs Latency in EU Central Region

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jul 31, 2026 - 14:23 UTC

Investigating

A subset of eth_getLogs requests on Monad Mainnet routed through our EU Central region are seeing increased delays.
Posted Jul 31, 2026 - 13:19 UTC
This incident affected: Monad.