Robinhood Mainnet - Increased Data API Latency and Error Rates

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Aug 27, 2026 - 20:47 UTC

Investigating

A subset of Data API requests on Robinhood Mainnet are experiencing increased latency and error rates.
Posted Aug 27, 2026 - 20:05 UTC